Задать вопрос
9 декабря, 16:15

Задача 1) Даны два числа а и b. Написать программу, которая находит меньшее из них и выводит на экран соответствующий результат. Задача 2) Дано целое число. Написать программу, которая заменяет его на 0, если число отрицательное, и выводит его без изменений, противном случае. Задача 3) Дано целое число n. Написать программу увеличивающую его на 10, если число больше 0.

+5
Ответы (1)
  1. 9 декабря, 20:10
    0
    Задача 1

    var

    a, b:Integer;

    Begin

    Read (a, b) ;

    if (a>b) then Writeln (b)

    else if (a
    else Writeln ('Числа равны') ;

    end.

    Задача 2

    var

    n:Integer;

    Begin

    Read (n) ;

    if (n<0) then Writeln (0)

    else Writeln (n) ;

    end.

    3 адача 3.

    var

    n:Integer;

    Begin

    Read (n) ;

    if (n>0) then Writeln (n+10)

    else Writeln (n) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача 1) Даны два числа а и b. Написать программу, которая находит меньшее из них и выводит на экран соответствующий результат. Задача 2) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы