Задать вопрос
22 августа, 01:23

1) составьте программу вычисления в массиве А, содержащего N элементов, произведения положительных чисел. Pascal

2) составьте программу вычисления суммы элементов от первого отрицательного и до конца. Pascal

+3
Ответы (1)
  1. 22 августа, 04:24
    0
    program massiv1;

    uses CRT;

    var i, N, P:integer;

    a:array [1 ... N] of integer;

    begin

    P:=1;

    read (N) ;

    for i:=1 to N do

    begin

    read a[i];

    end;

    for i:=1 to N do

    begin

    if a[i] >o

    then

    P:=P*a[i];

    end;

    write (P) ;

    readkey;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) составьте программу вычисления в массиве А, содержащего N элементов, произведения положительных чисел. Pascal 2) составьте программу ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы