Задать вопрос
27 марта, 01:22

Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение. Исходные данные задать вручную или с помощью генератора случайных чисел, учитывая формат элементов массива А. Тип результата определяется из контекста.

-Вычислить количество отрицательных элементов массива;

-сумму модулей элементов массива, расположенных после максимального элемента

+3
Ответы (1)
  1. 27 марта, 02:25
    0
    Const n=

    var a:array [1 ... n] of integer; (целый)

    i, k, i_max: byte; max, sum:integer;

    begin

    randomize; или for i:=1 to n do

    for i:=1 to n do readln (a[i]) ;

    a[i]:=random (100) ;

    k:=0

    for i:=1 to n do

    if a[i]<0 then k:=k+1];

    max:=0; i_max:=0;

    for i:=1 to n do

    if a[i]>max then begin max:=a[i]; i_max:=i; end;

    sum:=0;

    for i:=i_max to n do

    sum:=sum+a[i];

    writeln ('Количество отрицательных элементов ', k) ;

    writeln ('Сумма элементов ', sum) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Создать программу получения и обработки одномерного массива - вектора: Вычислить значения 35 элементов одномерного целочисленного массива F в интервале (-6, 10) с использованием генератора случайных чисел
Ответы (1)