Задать вопрос
1 сентября, 12:29

Дана строка. Среди символов строки встречаются цифры. Написать программу, вычисляющую сумму всех цифр строки.

+2
Ответы (1)
  1. 1 сентября, 16:17
    0
    Pascal

    ---

    var s:string;

    i, c, sum:integer;

    begin

    readln (s) ;

    sum: = 0;

    for i:=1 to Length (s) do

    if (s[i]>='0') and (s[i]<='9') then

    begin

    c:=ord (s[i]) - 48;

    sum:=sum+c;

    end;

    writeln (sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дана строка. Среди символов строки встречаются цифры. Написать программу, вычисляющую сумму всех цифр строки. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы