Задать вопрос
6 марта, 02:03

Паскаль. Составить программу, которая по введенному числу в диапазоне 0-15, выдает его соответствующий шестнадцатеричный эквивалент.

+4
Ответы (1)
  1. 6 марта, 02:34
    0
    uses

    SysUtils;

    var

    s:string;

    i, sum, multipler, temp:integer;

    begin

    multipler : = 1;

    Writeln ('Vvedite shestnadtsateri4noe 4islo') ;

    Readln (s) ;

    s : = Trim (s) ;

    for i: = Length (s) downto 1 do begin

    case s[i] of

    '1' ... '9' : temp : = StrToInt (s[i]) ;

    'A' ... 'F' : temp : = 10 + ord (s[i]) - ord ('A') ;

    'a' ... 'f' : temp : = 10 + ord (s[i]) - ord ('a') ;

    else

    Writeln ('Nedupustimii sumvol: ', s[i]) ;

    Readln;

    exit;

    end;

    sum : = sum + multipler * temp;

    multipler : = multipler * 16;

    end;

    Writeln (sum) ;

    Readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Паскаль. Составить программу, которая по введенному числу в диапазоне 0-15, выдает его соответствующий шестнадцатеричный эквивалент. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы