Задать вопрос
31 января, 11:06

Напишите программу в паскале.

Грузовой автомобиль выехал из одного города в другой со скоростью v1 км/ч

Через t ч в этом же направлении выехал легковой автомобиль со скоростью v2 км/ч. составить программу, определяющею, догонит легковой автомобиль грузовой через t1 х после своего выезда

+2
Ответы (1)
  1. 31 января, 14:22
    0
    const

    v1 = 5; / / Скорость грузовика

    v2 = 10; //Скорость легкового автомобиля

    t = 5; / / Задержка между выездом

    var

    t1 : integer; / / Время, от выезда легкового авто

    begin

    readln (t1) ;

    if v1 * (t + t1) < = v2 * t1 then

    writeln ('Догонит')

    else writeln ('Не догонит') ;

    end.

    { Уравнение зависимости координаты от времени

    x = xo + vt

    x0 = 0

    xg (t) = v1 * (t+t1)

    xl (t) = v2*t1

    xl (t) > = xg (t) }
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в паскале. Грузовой автомобиль выехал из одного города в другой со скоростью v1 км/ч Через t ч в этом же направлении ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы