Задать вопрос
29 июля, 11:00

Автоморфные числа

Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата.

Например 25²=625. Напишите программу,

которая находит все автоморфные числа на отрезке [a, b ].

Входные данные

Входная строка содержит два натуральных

числа - значения a и b, разделённых пробелами. Гарантируется, что a ≤ b.

Выходные данные

Программа должна вывести в одну строчку все

автоморфные числа на отрезке [ a, b ], разделив их пробелами. Если таких чисел нет,

программа должна вывести число - 1.

Примеры

входные данные

20 100

выходные данные

25 76

+2
Ответы (1)
  1. 29 июля, 12:20
    0
    Var a, b, a1, i, k, x, q:integer;

    begin

    readln (a, b) ;

    a1:=a;

    k:=0;

    while a0 do

    begin

    a:=a div 10;

    k:=k+1;

    end;

    x:=1;

    for i:=1 to k do

    x:=x*10;

    q:=-1;

    for i:=a1 to b do

    if i = ((i*i) mod x) then

    begin

    write (i, ' ') ;

    q:=i;

    end;

    if q=-1 then write (q) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Автоморфные числа Натуральное число называется автоморфным, если оно равно последним цифрам своего квадрата. Например 25²=625. Напишите ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы