Задать вопрос
30 октября, 04:28

Дан целочисленный массив из 10 элементов все элементы которого целые числа в интервале от - 1000 до 1000. напишите программу которая находит количество элементов всех нечетных элементов массива которые делятся на 3

на языке Pascal желательно

+3
Ответы (2)
  1. 30 октября, 06:40
    0
    Program E08;

    uses crt;

    var

    X: array[-1000 ... 1000] of integer;

    S, i, k: integer;

    begin

    clrscr;

    writeln ('Введите массив X:') ;

    for i:=1 to 10 do

    begin

    write ('X[', i:2,'] = = > ') ;

    readln (X[i])

    end;

    for i:=1 to 10 do

    write (X[i],' ') ;

    writeln;

    K:=0;

    for i:=1 to 10 do

    begin

    S:=X[i] mod 3;

    if S = 0 then

    K:=K+1

    end;

    writeln ('Ответ: ', K)

    end.
  2. 30 октября, 07:19
    0
    var a: array [1 ... 30] of integer;

    i, k: integer;

    begin

    ...

    k:=0;

    все в цикле (примерно так: for i:=1 to 10 do ...) (это чтобы прокручивать цикл)

    if ((a[i] mod 2=1) and (a[i] mod 3=0)) then k=k+1;

    writeln (k) ; end.

    что-то вроде этого, я уже точно не помню язык pascal;
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан целочисленный массив из 10 элементов все элементы которого целые числа в интервале от - 1000 до 1000. напишите программу которая ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы