Задать вопрос
11 июля, 22:19

Дан массив aa из nn целых чисел. Требуется определить, превосходит ли 100 сумма элементов, которые больше 20.

Формат входных данных

На первой строке входного файла записано натуральное число nn (n≤100) (n≤100) - число элементов в массиве. На следующей строке через пробел записаны элементы массива aa - целые числа (|ai|≤1000) (|ai|≤1000).

Формат выходных данных

Требуется вывести "YES", если сумма больше 100, иначе вывести "NO".

+3
Ответы (1)
  1. 12 июля, 00:06
    0
    Program s;

    var a:array [0 ... 100] of integer; / / 100-количество элементов массива, можно поменять на ваше число

    n, i, s:integer;

    begin

    write ('Введите число элементов массива : ') ;

    read (n) ; / / Количество элементов массива

    write ('Введите элементы массива через пробел : ') ; / / Эту строчку можно не писать (по желанию)

    for i:=1 to n do

    begin

    read (a[i]) ; / / Вводим элементы через пробел

    s:=s+a[i]; / / Суммируем элементы массива end;

    if s>100 then write (' Yes ')

    else write (' No ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив aa из nn целых чисел. Требуется определить, превосходит ли 100 сумма элементов, которые больше 20. Формат входных данных На ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Дан массив a из n целых чисел. Требуется сначала вывести элементы, стоящие на четных местах, затем - на нечетных. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется сначала вывести все четные элементы, затем - нечетные. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется вывести только элементы с четными значениями. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Дан массив a из n целых чисел. Требуется вывести только неотрицательные числа. Формат входных данных На первой строке входного файла записано натуральное число n (n≤100) - число элементов в массиве.
Ответы (1)
Задача D Три числа Дан массив из N целых чисел а1, а2, ..., an. Вам нужно проверить, есть ли в этом массиве три числа сумма которых равна нулю. Формат входных данных В первой строке входного файла содержится одно целое число N (1 ≤ N ≤ 2000).
Ответы (1)