Задать вопрос
13 марта, 21:30

1. составить программу и алгоритм находящую сумму цифр трехзначного числа

2. составить программу и алгоритм находящую все простые делители заданного числа

+4
Ответы (1)
  1. 13 марта, 23:35
    0
    Program gt;

    var s, a, b, c, n:longint;

    begin

    read (n) ;

    a:=n div 100;

    b: = (n mod 100) div 10;

    c:=n mod 10;

    s:=a+b+c;

    writeln (s) ;

    end.

    2)

    program gt;

    label 1;

    var p, n, i, j:longint;

    begin

    read (n) ;

    for i:=2 to n do

    begin

    if (n mod i=0) then begin

    p:=round (sqrt (i)) ;

    for j:=2 to p do

    begin

    if (i mod j=0) then goto 1;

    end;

    writeln (i) ;

    1:

    end;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. составить программу и алгоритм находящую сумму цифр трехзначного числа 2. составить программу и алгоритм находящую все простые делители ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы