Задать вопрос
28 марта, 01:50

написать программу которая вычисляет оптимальный вес пользователя сравнивая его с реальными выдаёт рекомендации о необходимости поправиться или похудеть. по формуле рост минус 100 ...

написать то легко но учитель сказал что б говорилось на сколько худеть или поправиться надо ... ((ну ни как не могу додуматься ((помогите ((вот сама написаная программа

Program Zadacha1;

Var ves, rost, optVes:integer;

Begin

write ('введите массу тела') ;

read (ves) ;

write ('введите рост в см') ;

read (rost) ;

optVes:=rost-100;

if ves>optVes then write ('вам необходимо похудеть') ;

if ves

+4
Ответы (1)
  1. 28 марта, 04:08
    0
    Program Zadacha1;

    Var ves, rost, optVes:integer;

    Begin

    write ('введите массу тела') ;

    read (ves) ;

    write ('введите рост в см') ;

    read (rost) ;

    optVes:=rost-100;

    if ves>optVes then write ('вам необходимо похудеть на', abs (optVes-ves)) ;

    if ves
    if ves=optVes then write ('ваш вес оптимальный')

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «написать программу которая вычисляет оптимальный вес пользователя сравнивая его с реальными выдаёт рекомендации о необходимости поправиться ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы