Задать вопрос
1 сентября, 12:41

Трехзначное число, записанное в шестнадцатеричной системе счисления, увеличива-ется вдвое от перестановки первой цифры в конец числа. Определите максимальное из таких чисел, записанное в системе счисления по основанию 16.

+1
Ответы (1)
  1. 1 сентября, 15:58
    0
    Var

    i, j, k, ix, jx, kx:integer;

    s:string;

    function per (x:integer) : string;

    begin

    case x of

    10: result:='A';

    11: result:='B';

    12: result:='C';

    13: result:='D';

    14: result:='E';

    15: result:='F';

    else

    str (x, result) ;

    end;

    end;

    begin

    for i:=1 to 15 do

    for j:=0 to 15 do

    for k:=0 to 15 do

    if 2 * (i*16*16+j*16+k) = j*16*16+k*16+i then

    begin

    ix:=i;

    jx:=j;

    kx:=k;

    end;

    s:=per (ix) + per (jx) + per (kx) ;

    writeln (s) ;

    end.

    В результате работы программы получаем ответ.

    Ответ: 6DB
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Трехзначное число, записанное в шестнадцатеричной системе счисления, увеличива-ется вдвое от перестановки первой цифры в конец числа. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы