Задать вопрос
19 марта, 19:29

Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа, а второе из четных. вывести новые числа.

+4
Ответы (1)
  1. 19 марта, 20:34
    0
    Не самый рациональный метод решения, но как говорится чем смог тем помог)

    var a, b, c, x, kc, kn, k1, k2:integer;

    begin

    kc:=1;

    kn:=1;

    k1:=0;

    k2:=0;

    a:=0;

    b:=0;

    writeln ('Введите число x') ;

    read (x) ;

    while x>0 do begin

    c:=x mod 10;

    if c mod 2=0 then begin

    inc (k1) ;

    a:=a+c*kc;

    kc:=kc*10;

    end;

    if c mod 20 then begin

    inc (k2) ;

    b:=b+c*kn;

    kn:=kn*10;

    end;

    x:=x div 10;

    end;

    if k1>k2 then writeln ('Четных больше нечетных') else if k1=k2 then writeln ('Количество четных = количеству нечетных') else writeln ('Четных меньше нечетных') ;

    writeln (a,' ', b) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы