Задать вопрос
19 сентября, 15:24

Напишите программу в которой одномерный массив на 10 элементов, нужно заполнить по формуле только четными значениями. Выведите массив строчку. Найдите количество значений лежащих в промежутке [6 до 20] (включительно 20). Произведение тех, которые больше 10

+3
Ответы (1)
  1. 19 сентября, 19:06
    0
    Var A:array[1 ... 10] of Integer;

    i, N, k, l, j:integer;

    begin

    Readln (N) ;

    For i:=1 to N do

    A[i]:=Random (1,10) ;

    For i:=1 to N do

    Write (A[i],' ') ;

    Writeln;

    For i:=1 to N do

    If (A[i]>=6) and (A[i]<=20) then

    k:=k+1;

    Writeln ('количество значений лежащих в промежутке [6 до 20] ', k) ;

    For i:=1 to N-1 do

    For j:=i+1 to N do

    If A[i]*A[j]>10 then

    l:=l+1;

    Writeln ('количество значений п роизведение которых больше 10 ', l) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в которой одномерный массив на 10 элементов, нужно заполнить по формуле только четными значениями. Выведите массив ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы