Задать вопрос
18 марта, 02:53

Ребят, помоги в паскале. напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0. В конце работы программы на экран выводится сумма и произведение введенных чисел.

+4
Ответы (1)
  1. 18 марта, 05:27
    0
    Var a, s, p:integer;

    begin

    p:=1;

    read (a) ;

    if (a=0) then p:=0;

    while (a0) do begin

    s+=a;

    p*=a;

    read (a) ; end;

    writeln (s, ' ', p) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Ребят, помоги в паскале. напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0. В конце работы ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы