Задать вопрос
10 марта, 15:44

Составьте программу, которая заполняет массив [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и последний элементы. Выведите на экран исходный и полученный массивы.

+1
Ответы (1)
  1. 10 марта, 16:24
    0
    Program Program1;

    Var

    a:array [1 ... 10] of integer;

    i, temp:integer;

    begin

    randomize;

    writeln ('Исходный массив:') ;

    for i:=1 to 10 do

    begin

    a[i]:=random (10) + 1;

    writeln ('a[', i,']=', a[i]) ;

    end;

    temp:=a[1];

    a[1]:=a[10];

    a[10]:=temp;

    writeln;

    writeln ('Полученный массив:') ;

    for i:=1 to 10 do

    writeln ('a[', i,']=', a[i]) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, которая заполняет массив [1 ... 10] случайными целыми числами в диапазоне от 1 до 10, затем меняет местами первый и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы