Задать вопрос
22 декабря, 18:54

Дан массив с1, с2, ..., с15, состоящий из нулей и единиц. Подсчитать количество нулей, количество единиц и количество нулей до первой единицы. Это в паскале

+3
Ответы (1)
  1. 22 декабря, 20:50
    0
    Uses crt;

    const max=15;

    var a : array[1 ... max] of integer;

    i, k0, k1, k3 : integer;

    k:boolean;

    begin

    randomize;

    k0:=0;

    k1:=0;

    writeln ('исходные:') ;

    for i:=1 to max do

    begin

    a[i]:=random (2) ;

    write (a[i]:4) ;

    end;

    for i:=1 to 15 do

    begin

    if a[i]=0 then inc (k0) else inc (k1) ;

    if a[i]0 then k:=true;

    if k=false then inc (k3) ;

    end;

    writeln;

    writeln ('количество нулей = ', k0) ;

    writeln ('количество единиц = ', k1) ;

    writeln ('количество нулей до первой единицы = ', k3) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив с1, с2, ..., с15, состоящий из нулей и единиц. Подсчитать количество нулей, количество единиц и количество нулей до первой ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Написать на языке pascal. Дан массив с1, с2 ... с15 состоящий из нулей и единиц. Подсчитать количество 0, количество 1, и количество нулей до первой единицы
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
1.) Вывести на экран одномерный целочисленный массив, состоящий из 10 целых чисел из диапазона [-100; 100] 2.) Задан одномерный целочисленный массив, состоящий из 7 случайных чисел.
Ответы (1)