Задать вопрос
3 мая, 00:57

В этом году третий раз одна известная компания проводит соревнование по программированию искусственного интеллекта для игровых стратегий. В этот раз участникам предложили написать искусственный интеллект для управления командой хоккеистов. Научившись оценивать время, за которое хоккеист сможет догнать шайбу, Вася решил использовать это для улучшения своей стратегии. Оказалось, что не всегда выгодно ехать к шайбе защитнику, так как нападающий соперника может перехватит ее раньше и выйти один на один с вратарем. Чтобы избежать подобных провалов в обороне нужно еще определить, через сколько противник сможет подобрать шайбу. Вася уже вычислил, что первому хоккеисту соперника понадобится для этого A условных единиц времени, а второму - B. Помогите ему подсчитать, через какое наименьшее время противник сможет подобрать шайбу.

Формат ввода

Во входном файле заданы два целых числа A и B (0 ≤ A, B ≤ 109) - за какое время хоккеисты соперника смогут подобрать шайбу.

+2
Ответы (2)
  1. 3 мая, 01:36
    0
    Блин сам не могу решить
  2. 3 мая, 02:17
    0
    program z1;

    var

    a, b, c:int64;

    input, output:text;

    begin

    assign (input,'input. txt') ;

    reset (input) ;

    assign (output,'output. txt') ;

    rewrite (output) ;

    readln (input, a, b) ;

    begin

    if a
    c:=a else

    c:=b

    end;

    writeln (output, c) ;

    close (input) ;

    close (output) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В этом году третий раз одна известная компания проводит соревнование по программированию искусственного интеллекта для игровых стратегий. В ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы