Задать вопрос
16 мая, 23:38

Составьте задачу в Паскаль с помощью while. На каждом следующем дне рождения Винни Пух съедает столько же меда, сколько съел на двух предыдущих вместе. На двух первых днях рождения у Пятачка и Кролика он съел по 100 г меда. Определите, сколько килограммов меда он съест на десятом дне рождения.

+1
Ответы (1)
  1. 17 мая, 02:54
    0
    Числа Фибоначчи (вместо 1 только 100) !

    var m1, m2, s, i:integer;

    begin

    m1:=100; m2:=100;

    for i:=3 to 10 do

    begin

    s:=m1+m2;

    m1:=m2;

    m2:=s;

    end;

    writeln (s) ;

    end.

    Результат:

    5500
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте задачу в Паскаль с помощью while. На каждом следующем дне рождения Винни Пух съедает столько же меда, сколько съел на двух ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы