Задать вопрос
31 октября, 05:03

Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел. Если произведение этих четырех чисел больше их суммы, то выведите эти сумму и произведение. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму. Иначе, выведите удвоенные значения этих чисел.

+5
Ответы (1)
  1. 31 октября, 08:36
    0
    Var a, b, c, d:real;

    begin

    readln (a, b, c, d) ; i

    f (a<0) and (b/c=2) then

    begin

    writeln ((a+b+c+d) / 4) ;

    if a*b*c*b>a+b+c+d then

    begin

    writeln (a*b*c*b) ;

    writeln (a+b+c+d) ;

    end;

    end

    else

    writeln (a*2,' ', b*2,' ', c*2,' ', d*2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы