Задать вопрос
10 апреля, 13:29

Жили были дед и баба и был у них огород прямоугольной формы со сторонами A, B. После ссоры они решили поделить огород, при этом дед может взять себе не больше половины огорода (размеры участков после раздела должны быть целыми и участки прямоугольными). Вывести '1' - если участок деда оказался меньше, '0' - если участки равны.

Входные данные:

Во входном потоке в первой строке заданы целые числа A, B (A, B < 1000).

Выходные данные:

Вывести единственное целое число.

Пример входного файла (input. txt) :

8 4

+1
Ответы (1)
  1. 10 апреля, 17:04
    0
    Из условия неясно, как определяются размеры участков огорода - линейными размерами или площадью. Т. е. что должно быть целым - линейные размеры или площадь? Будем считать, что целыми должны быть линейные размеры.

    Это означает, что достаточно среди чисел А и В найти четное и разделить его пополам. В этом случае участок деда будет равен половине огорода. Если оба числа нечетных, деду достанется меньше половины огорода.

    var

    A, B:integer;

    f:Text;

    begin

    Assign (f,'input. txt') ;

    Reset (f) ;

    readln (f, A, B) ;

    writeln ('Размеры участка ', A,', ', B) ;

    if (A mod 2=0) or (B mod 2=0) then writeln ('0')

    else writeln ('1')

    end.

    Результат решения:

    Размеры участка 8, 4

    0
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Жили были дед и баба и был у них огород прямоугольной формы со сторонами A, B. После ссоры они решили поделить огород, при этом дед может ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы