Задать вопрос
3 ноября, 19:56

Дано натуральное число. Определить количество единиц в записи данного числа в двоичной системе счисления

+4
Ответы (1)
  1. 3 ноября, 21:21
    0
    Var

    n, k: longint;

    begin

    Write ('Введите натуральное число: ') ; Readln (n) ;

    k : = 0;

    if n > 1 then

    begin

    repeat

    if n mod 2 = 1 then k : = k + 1;

    n : = n div 2

    until n < 2

    end;

    Writeln ('Количество единиц в двоичном представлении равно ', k + 1)

    end.

    Тестовое решение:

    Введите натуральное число: 152

    Количество единиц в двоичном представлении равно 3
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано натуральное число. Определить количество единиц в записи данного числа в двоичной системе счисления ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
А) 1000001110 в двоичной системе счисления+1100110 в двоичной системе счисления б) 10001001 в двоичной системе счисления-1010101 в двоичной системе счисления в) 45 в восьмеричной системе счисления * 71 в восьмеричной системе счисления г) 1AF1 в
Ответы (1)
1. Выполните сложение в двоичной системе счисления: 101112 + 1011102 Результат запишите в двоичной системе счисления. 2. Выполните сложение в двоичной системе счисления: 11012 + 110112 Запишите ответ в двоичной системе счисления.
Ответы (1)
1) Десятичное число 4563 в двоичной системе счисления равно 2) Десятичное число 800 в восьмеричной системе счисления равно 3) Десятичное число 781 в шестнадцатеричной системе счисления равно 4) Двоичное число 1000000 в десятичной системе счисления
Ответы (1)
Сколько единиц в двоичной записи числа 195? Сколько единиц в двоичной записи числа 173? Как представлено число 25 в двоичной системе счисления? Как представлено число 82 в двоичной системе счисления?
Ответы (1)
1. Запишите число 156 в шестнадцатеричной системе счисления. 2. Запишите число AD16 В десятичной системе счисления. 3. Запишите число 111100000012 в шестнадцатеричной системе счисления. 4. Запишите число 125 В 16 В двоичной системе счисления. 5.
Ответы (1)